import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([^<>()\\[\\]\\.,;:\\s@\\\"]{1,64}(\\.[^<>()\\[\\]\\.,;:\\s@\\\"]+)*)|(\\\".+\\\"))@\\[*(?!.*?\\.\\.)(([^<>()[\\]\\.,;\\s@\\\"]+\\.?)+[^<>()[\\]\\.,;\\s@\\\"]{2,})\\]?";
final String string = "prettyandsimple@example.com\n"
+ "very.common@example.com\n"
+ "disposable.style.email.with+symbol@example.com\n"
+ "other.email-with-dash@example.com\n\n"
+ "(one-letter local part)\n"
+ "x@example.com\n\n"
+ "\"much.more unusual\"@example.com\n"
+ "\"very.unusual.@.unusual.com\"@example.com\n"
+ "\"very.(),:;<>[]\\\".VERY.\\\"very@\\\\ \\\"very\\\".unusual\"@strange.example.com\n"
+ "example-indeed@strange-example.com\n"
+ " \n"
+ "(local domain name with no TLD)\n"
+ "admin@mailserver1\n\n"
+ "#!$%&'*+-/=?^_`{}|~@example.org\n"
+ "\"()<>[]:,;@\\\\\\\"!#$%&'*+-/=?^_`{}| ~.a\"@example.org\n\n"
+ "(space between the quotes)\n"
+ "\" \"@example.org\n\n"
+ "example@localhost\n"
+ "example@s.solutions\n"
+ "user@com\n"
+ "user@localserver\n"
+ "user@[2001:DB8::1][\n"
+ "user@[IPv6:2001:db8::1]\n"
+ "©other.email-with-dash@example.com\n"
+ "?prettyandsimple@example.com\n"
+ "用户@例子.广告\n"
+ "अजअय@डाअटा.भारत\n"
+ "квіточка@пошта.укр\n"
+ "θσερ@εχαμπλε.ψομ\n"
+ "Dörte@Sörensen.example.com\n"
+ "аджай@экзампл.рус\n\n\n"
+ "Invalid email addresses[edit]\n\n"
+ "(no @ character)\n"
+ "Abc.example.com\n\n"
+ "(only one @ is allowed outside quotation marks)\n"
+ "A@b@c@example.com\n\n"
+ "(none of the special characters in this local part are allowed outside quotation marks)\n"
+ "a\"b(c)d,e:f;g<h>i[j\\k]l@example.com\n\n"
+ "(quoted strings must be dot separated or the only element making up the local part)\n"
+ "just\"not\"right@example.com\n\n"
+ "(spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)\n"
+ "this is\"not\\allowed@example.com\n\n"
+ "(even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)\n"
+ "this\\ still\\\"not\\\\allowed@example.com\n\n"
+ "(double dot before @)\n"
+ "john..doe@example.com\n"
+ "with caveat: Gmail lets this through, Email address#Local-part the dots altogether\n\n"
+ "(double dot after @)\n"
+ "john.doe@example..com\n\n"
+ "(exceeds 64 characters in local part)\n"
+ "1234567890123456789012345678901234567890123456789012345678901234+x@example.com\n"
+ "alskjnakjanv1wadfqaebbsfdfagfbnbKJANDVlvn13dcljnvzlkjbnadlkgf3cjnj@winnipeg.com\n";
final String subst = "QuestionText = \"$1\",";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}