re = /( ?.)\1{2,}/
str = 'llllllll
kkkkkkk
llll
fflllllllllll
lllll
llllllllllll
zoolosss~~~~~~~~~~~~!!!!!!!!!!!!!!!!!!'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result