$re = '/(?:(?:word1|word2|word3) *)+/m';
$str = 'i m word1word2 and this is word3word2 word1+ i am having this word2 word3.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);