$re = '/^(?:(?!EMP|NDB|POI|CWR)[A-Za-z\s]){1,25}$/m';
$str = 'BLA
EMP
BLABLA
NDB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);