re = /^\{+(\{.*?\})\}+$/
str = '{{{{{{{{{{{{{{{{{{{{Valor aqui dentro}}}}}}}}}}}}}}}}}}}}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end