const regex = /[^\wćĆčČžŽšŠđĐ{Cyrillic}](ime)[\s:]{1}.*?([\wćĆčČžŽšŠđĐ{Cyrillic}]+)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\wćĆčČžŽšŠđĐ{Cyrillic}](ime)[\\s:]{1}.*?([\\wćĆčČžŽšŠđĐ{Cyrillic}]+)', 'ig')
const str = `Osnovne informacije Ime: Maša Prezime: Dragovic Datum rođenja: 21.02.1995 Adresa: Kozaracka 31,Podgorica,Crna Gora Mobilni telefon: 0679226293 E-mail: masa.dragovic@college.wlc.ac.uk Оbrаzоvаnjе Naziv institucije: Srednja Ekonomska Skola "Mirko Vesovic" Smjer: Ekonomski tehnicar Stepen obrazovanja: Srednja škola Početak / završetak: 2010 - 2012 Naziv institucije: Ealing Hammersmith and West London College Smjer: BTEC Business, Managerment and Economic Stepen obrazovanja: Viša stručna sprema Početak / završetak: 2013 - 2016 Iskustvо u pоslu Nаziv pоslа: Aspects Beauty menadzer Nаziv kоmpаniје: Aspects Beauty, Debenhams, London Početak / završetak: Srednja škola Početak / završetak: Nov. 2012 - Mar. 2016 Оpis pоslа: Aktivna uloga prodavca i promotera. Odgovornost cjelokupnog prostora i uspjeha kompanije tokom cijelog vremena. Kontrola nad magacina, proizvoda i saradnje. Nаziv pоslа: Aspects Beauty menadzer Nаziv kоmpаniје: John Lewis, London Početak / završetak: Viša stručna sprema Početak / završetak: Nov. 2013 - Feb. 2014 Оpis pоslа: Puna odgovornost upravljanja preduzeca. Pruzanje profesionalnih usluga. Odgovornost organizacije agencija, radnog vremena i pauza. Nаziv pоslа: Menadzer smjene Nаziv kоmpаniје: La Piccola Dely, London Početak / završetak: 1 / 2 Početak / završetak: May. 2015 - Sep. 2015 Оpis pоslа: Puna odgovornost organizacije radnika, smjena, poslova, papirologije, nivoa proizvoda, dobavljaca i prodaje. Nаziv pоslа: Pomocni barmen Nаziv kоmpаniје: Defectors, London Početak / završetak: Početak / završetak: Feb. 2014 - Aug. 2014 Оpis pоslа: Odgovornost cjelokupne pripreme smjene. Posao je zahtijevao brzinu, dinamicnost i pruzanje prijateljskih usluga. Nаziv pоslа: Menadzer smjene Nаziv kоmpаniје: Picasso Bar, Spain Početak / završetak: Početak / završetak: Mar. 2016 - Apr. 2016 Оpis pоslа: Odgovornost za organizaciju smjena, dostave, nivoa proizvoda. Nabavljanje svog potrebnog materijala za posao. Papirologiga na nedeljnom nivou. Poznavanje jezika Engleski jezik: Profesionalno Španski jezik: Profesionalno Poljski: Napredno Vještine - Poznavanje racunara i programa. Fleksibilnost radnog vremena. Odgovornost i tacnost na radnom mjestu. Konunikativnost, ljubaznost i strpnjenje. Lak ulazak u komunikaciju i lako privlacenje paznje musterija. Poznavanje vise jezika. Radno iskustvo na razlicitim sverama posla sa razlicitim profilima ljudi. Powered by TCPDF (www.tcpdf.org) 2 / 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}