const regex = /^(\S+|\S+\s+\d+\s+\S+) \S+ H=\S+ \[(\S+)\]:\d+? sender verify fail for <(\S+)>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+|\\S+\\s+\\d+\\s+\\S+) \\S+ H=\\S+ \\[(\\S+)\\]:\\d+? sender verify fail for <(\\S+)>', '')
const str = `2015-10-25 12:47:56 H=177-66-137-33.clonix.srv.br [177.66.137.33]:10000 sender verify fail for <fakeuser@domainname>:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}