import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*postfix\\/smtpd\\[.*\\]: NOQUEUE: reject: RCPT from (\\S+)\\[(\\S+)\\]: 450 4.1.1 <(\\S+)>.*$";
final String string = "Apr 29 21:50:41 server postfix/smtpd[20416]: NOQUEUE: reject: RCPT from mona.bmstech.com.au[203.33.248.10]: 450 4.1.1 <Raymond_Elmo@mromarket.com>: Recipient address rejected: User unknown in virtual mailbox table; from=<> to=<Raymond_Elmo@mromarket.com> proto=ESMTP helo=<mail.bmstech.com.au>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}