package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(?:dp|product)\/|[&?]page=`)
var str = `http://www.amazon.in/s/lp_6563520031_pg_2?rh=n%3A5866078031%2Cn%3A%215866079031%2Cn%3A6563520031&page=2s&ie=UTF8&qid=1446802571
http://www.amazon.in/Tena-Wet-Wipe-Pulls-White/dp/B001O1G242/ref=sr_1_46?s=industrial&ie=UTF8&qid=1446802608&sr=1-46`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}