$re = '/(W\d{3}\.\d{2})(\.\d{2})?$/';
$str = 'W100.01.01';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);