import re
regex = re.compile(r"^((((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{6})|((0|8)((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{5})|((00|99|98)((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{4})|(111((2(0[1-9]|[1-9][0-9]))|([3-6][0-9]{2})|(7([0-6][0-9]|7[0-5])))[0-9]{3})|((970|972|974)[0-9]{6}))$", flags=re.MULTILINE)
test_str = ("000000000\n"
"1193046\n"
"100000000\n"
"111111111\n"
"123456789\n"
"222222222\n"
"999999999\n"
"201000000\n"
"200123456\n"
"775123456\n"
"776123456\n"
"7751234562\n"
"111456000\n"
"077500000\n"
"877500000\n"
"002010000\n"
"995642323\n"
"988885687\n"
"986885687\n"
"970123456\n"
"972000000\n"
"974999999\n"
"975999999\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")