$re = '/[0-9]*:([0-9]{4}):([0-9]{2})\/([0-9]{4})/';
$str = '123456:1234:05/2015';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);