# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*[a-zA-Z_]?.*void\s+[a-zA-Z_][a-zA-Z_0-9]*\s*\((?s).*?\).*?$"
test_str = ("\n\n\n"
"extern inline void\n"
"lineBreak ( void )\n\n"
";\n\n\n"
"extern inline void debugPrintf\n"
"(\n"
"const int level,\n"
" const char * const format,\n"
"...)\n"
"{\n"
"return NULL;\n"
"}\n\n"
"extern void\n"
"debugPutc\n"
"(\n"
"const int level\n"
",\n"
"const int c)\n"
";\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.