$re = '/^(.*(text "|choice ").*)$/m';
$str = 'text "","text1"
waitinput
text "","text2"
waitinput
text "{user}","text3"
waittext
choice "option1","option2"
text "","text4"
waitinput
text "{user}","text5"
waitinput
text "char","text6"
waitinput';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);