import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([a-zA-Z0-9-: ])+)(https:\\/\\/la100.cienradios.com\\/.+([a-zA-Z0-9-\\/]+)[^\"])";
final String string = "'<h2>No hay dudas de que Peaky Blinders es un gran suceso desde su estreno en 2013. En esta nota la diferencia que existe entre la ficción y la realidad.</h2>\n\n"
+ "<hr />\n\n"
+ "[caption id=\"attachment_827892\" align=\"aligncenter\" width=\"745\"]<img class=\"wp-image-827892 size-full\" src=\"https://la100.cienradios.com/wp-content/uploads/sites/4/2020/09/Untitled-1-4.jpg\" alt=\"Peaky Blinders: las situaciones de la serie que sucedieron en la vida real\" width=\"745\" height=\"483\" /> Peaky Blinders: las situaciones de la serie que sucedieron en la vida real[/caption]\n\n"
+ "La serie <strong>Peaky Blinders</strong> es una de las más vistas y más queridas por el público. Se espera la sexta temporada de la mano de la BBC, será el momento en que <a href=\"https://la100.cienradios.com/la-historia-de-la-actriz-de-peaky-blinders-que-vivio-en-argentina/\">Tommy Shelby (interpretado por Cillian Murphy) volverá una vez más. </a>\n\n"
+ "Cabe destacar que el final de la quinta temporada, no fue del todo feliz. De hecho, esto despertó la curiosidad en muchos espectadores de sí las historias que vemos en <strong>Peaky Blinders</strong> <a href=\"https://la100.cienradios.com/peaky-blinders-la-sexta-temporada-ya-tiene-fecha-de-estreno/\">ocurrió verdaderamente con la famosa pandilla de Birmingham.</a>\n\n"
+ "En lo que respecta enemigos de Shelby sin dudas de que son verídicos, sin embargo los guionistas de la serie aseguran que sin embargo, algunos eventos en la serie no son reales.\n\n"
+ "<strong>Tal es el caso del personaje Oswald Mosley, quien estuvo en la temporada 5, esta se trató de una figura controvertida debido a que él realmente inició la Unión Británica de Fascistas. En lo que respecta a la muerte de este hombre, destacaron que habría un poco de ficción. A su vez, al final de la temporada 5, Shelby tenía planes de asesinarlo, sin embargo hay un detalle con las fechas, ya que Mosley falleció en el año 1980.</strong>\n\n"
+ "A su vez, algunos eventos históricos también fueron adaptados para poder sumarlos a la historia de la familia Shelby. A pesar de que los fieles seguidores de esta serie, por una cuestión de fechas, saben que no es cierto, confían en la trama.Hasta el momento, la sexta temporada de Peaky Blinders no tiene fecha de lanzamiento oficial por parte de la BBC.\n\n"
+ "<img class=\"wp-image-827894 size-full aligncenter\" src=\"https://la100.cienradios.com/wp-content/uploads/sites/4/2020/09/Untitled-2-2.jpg\" alt=\"Peaky Blinders: las situaciones de la serie que sucedieron en la vida real\" width=\"745\" height=\"483\" />\n\n"
+ "Peaky Blinders: las situaciones de la serie que sucedieron en la vida realhttps://la100.cienradios.com/peaky-blinders-la-cancion-de-la-serie-tiene-un-significado-que-pocos-conocen/\n\n"
+ "Escuchá La 100 todo el día <a href=\"https://la100.cienradios.com/player/la100/?utm_source=player&utm_medium=la100&utm_campaign=linksennotasla100\">hacé click acá</a>\n\n"
+ "Si querés escuchar Radio Mitre <a href=\"https://radiomitre.cienradios.com/player/mitre_am790/?utm_source=player&utm_medium=radiomitre&utm_campaign=linksennotasla100\">hacé click acá</a>\n\n"
+ "Seguinos en <a href=\"https://www.youtube.com/la100\" target=\"_blank\" rel=\"noopener noreferrer\">YouTube</a>'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}