re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[-+_!@#$%^&*., ?])/m
str = '1GoodPassword!
1allmostpassword!
323488838S@e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end