#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((http[s]?\:)\/\/)?([^\?\:\/#]+)(\:([0-9]+))?(\/[^\?\#]*)?(\?([^#]*))?(#.*)?"
Local $sString = "http://127.0.0.1:8080/some/path?a=1&b=2&a=3#asdflk" & @CRLF & _
                "www.url-with-querystring.com/?url=has-querystring" & @CRLF & _
                "http://www.google.com#!something" & @CRLF & _
                "http://www.google.com?a=1&b=2&a=3" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")