package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\[\]]+)`)
var str = `string1[string2][string3]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}