#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(datatype\s+: 4\b(?:(?!datatype\s+: \d)[\s\S])*?(maxlength\s+:\s0\b))"
Local $sString = "field {" & @CRLF & _
" id : 536870914" & @CRLF & _
" name : Set Field (Submit Mode)" & @CRLF & _
" datatype : 4" & @CRLF & _
" fieldtype : 1" & @CRLF & _
" create-mode : 2" & @CRLF & _
" option : 2" & @CRLF & _
" timestamp : 1489159658" & @CRLF & _
" owner : John Smith" & @CRLF & _
" last-changed : John Smith" & @CRLF & _
" length-units : 0" & @CRLF & _
" maxlength : 0" & @CRLF & _
" clob-store-opt : 0" & @CRLF & _
" menu-style : 1" & @CRLF & _
" qbe-match-op : 1" & @CRLF & _
" fulltext-optns : 0" & @CRLF & _
" permission : 12\1" & @CRLF & _
"}" & @CRLF & _
"field {" & @CRLF & _
" id : 536870915" & @CRLF & _
" name : Schema Name" & @CRLF & _
" datatype : 4" & @CRLF & _
" fieldtype : 1" & @CRLF & _
" create-mode : 2" & @CRLF & _
" option : 1" & @CRLF & _
" timestamp : 1165057260" & @CRLF & _
" owner : John Smith" & @CRLF & _
" last-changed : John Smith" & @CRLF & _
" length-units : 0" & @CRLF & _
" maxlength : 30" & @CRLF & _
" clob-store-opt : 0" & @CRLF & _
" menu-style : 1" & @CRLF & _
" qbe-match-op : 1" & @CRLF & _
" fulltext-optns : 0" & @CRLF & _
" permission : 12\1" & @CRLF & _
"}" & @CRLF & _
"field {" & @CRLF & _
" id : 536870916" & @CRLF & _
" name : Type" & @CRLF & _
" datatype : 4" & @CRLF & _
" fieldtype : 1" & @CRLF & _
" create-mode : 2" & @CRLF & _
" option : 1" & @CRLF & _
" timestamp : 1165057260" & @CRLF & _
" owner : John Smith" & @CRLF & _
" last-changed : John Smith" & @CRLF & _
" length-units : 0" & @CRLF & _
" maxlength : 30" & @CRLF & _
" clob-store-opt : 0" & @CRLF & _
" menu-style : 2" & @CRLF & _
" qbe-match-op : 1" & @CRLF & _
" fulltext-optns : 0" & @CRLF & _
" permission : 12\1" & @CRLF & _
"}" & @CRLF & _
"field {" & @CRLF & _
" id : 536870917" & @CRLF & _
" name : Set Field (Query Mode)" & @CRLF & _
" datatype : 4" & @CRLF & _
" fieldtype : 1" & @CRLF & _
" create-mode : 2" & @CRLF & _
" option : 2" & @CRLF & _
" timestamp : 1489159658" & @CRLF & _
" owner : John Smith" & @CRLF & _
" last-changed : John Smith" & @CRLF & _
" length-units : 0" & @CRLF & _
" maxlength : 0" & @CRLF & _
" clob-store-opt : 0" & @CRLF & _
" menu-style : 1" & @CRLF & _
" qbe-match-op : 1" & @CRLF & _
" fulltext-optns : 0" & @CRLF & _
" permission : 12\1" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")