#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(?:https?:\/\/)?(?:(?:www\.)?youtube\.com\/(?:(?:v\/)|(?:embed\/|watch(?:\/|\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\.)?youtu\.be\/)([A-Za-z0-9_\-]+)&?.*$"
Local $sString = "http://www.youtube.com/watch/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/v/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/v/i_GFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related " & @CRLF & _
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA" & @CRLF & _
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail" & @CRLF & _
"http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA " & @CRLF & _
"https://www.youtube.com/watch?v=iwGFalTRHDA " & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related " & @CRLF & _
"http://youtu.be/iwGFalTRHDA " & @CRLF & _
"http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/embed/watch?v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/embed/v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"www.youtube.com/watch?v=iwGFalTRHDA " & @CRLF & _
"www.youtu.be/iwGFalTRHDA " & @CRLF & _
"youtu.be/iwGFalTRHDA " & @CRLF & _
"youtube.com/watch?v=iwGFalTRHDA "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)