$re = '/^(?=.*\bB1\b)(?=.*\bB2\b)(?=.*\bB3\b)(?=.*\bB4\b)(?=.*\bB5\b)(?:.*?[.?!](?: |$)){10}.*/mis';
$str = 'Lorem ipsum dolor sit amet consectetur adipiscing elit b3. Ex sapien vitae pellentesque sem placerat in id. Pretium tellus duis convallis tempus leo eu aenean. Urna tempor pulvinar vivamus fringilla lacus nec metus. Iaculis massa nisl malesuada lacinia integer nunc posuere. (B1) Semper vel class aptent taciti (B4 - duis tellus id) sociosqu ad litora. Conubia nostra inceptos himenaeos orci varius natoque penatibus. Dis parturient montes nascetur ridiculus mus donec rhoncus. Nulla molestie mattis scelerisque maximus eget fermentum odio. Purus est efficitur laoreet mauris pharetra vestibulum fusce (b2) sfnj B5.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);