const regex = new RegExp('\\[\\'g', 'gm')
const str = `'Sheet1', [['_', 'd', 0], ['g', 'p', 0], ['b', 'v', 0], ['-', ',', 0], ['a', ')', 0.01],`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}