import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( # 1: start\n"
+ "( # 2: look for header...\n"
+ "( # 3: start\n"
+ "(ht|f)tps?\\: # 4: http or some variant, or\n"
+ ")| # 3: end.\n"
+ "(www) # 5: www.\n"
+ ") # done with header.\n"
+ "(?: # start repeating group\n"
+ "([.\\/:?=&-]+) # 6: allowed punctuations\n"
+ "( # 9: start. chose one:\n"
+ "(((\\s?)([a-z0-9]+) # a space and lower case chars \n"
+ ")| #or\n"
+ "(\\w+) # 11: all word chars, but no spaces\n"
+ ")\n"
+ ") # 9: end.\n"
+ ")+ # end repeating group\n"
+ ") # end capture group 1\n"
+ "(\\/?\\.?\\s?[A-Z]?) # exclude this.";
final String string = " us at https://www.roblox.com/support. If anyone asks for your password or personal information (such as your name, address or (https://www.roblox.com/support). If we choose to take action, Devs and Payors agree that our decision (which may include deducting Robux from the Dev and crediting of Robux to the Payor) is final and Devs and Payors shall abide by that decision. You agree to work with us in a timely manner to resolve all such issues, and failure to do so is considered a violation of these Terms.\n"
+ "B. Privacy Policy. At all times your information will be treated in accordance with Appleās Privacy Policy, which is incorporated by reference into this License and can be viewed at: http:// www.apple.com/privacy/.";
final String subst = "--------->$1<--------$13";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}