$re = '/(word )(= )([0-9])/m';
$str = 'word = 4
word = 2
word = 8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);