const regex = /^\[img(((width|height|align)=(([0-9]+)|(left|right|middle|top|bottom)) )+)\](.*?)\[\/img\]$/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[img(((width|height|align)=(([0-9]+)|(left|right|middle|top|bottom)) )+)\\](.*?)\\[\\\/img\\]$', 'is')
const str = `[img width=100 height=100 align=right]thelinktotheimage[/img]
[img align=right]thelinktotheimage[/img]
[img width=100 height=100]thelinktotheimage[/img]
[img width=100]thelinktotheimage[/img]
[img height=100]thelinktotheimage[/img]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}