$re = '/(?=(aga)).{2}(?<=.)(\1)/';
$str = 'tagagaga';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);