re = /(<img (.*? )*?src=")([^:]*?)"\//
str = '<img bla="blubb" src="/foo"/>lalala</img>text<img bla="blubb" src="p://foo"/>lalala</img>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end