package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((([A-Z][A-Z]{0,1})[0-9][A-Z0-9]{0,1}) {0,}[0-9])[A-Z]{2})$`)
var str = `SW1A 1AA`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}