$re = '/\w{1}:\/\/([a-zA-Z0-9\-\_\s]+\/)*\w+\.\w+/';
$str = 'c://program files/system32/data.dat';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);