import re
regex = re.compile(r"^https?:\/\/(.*addons|au[0-9])\.mozilla\.(org|net|com)\.*")
test_str = ("https://addons.mozilla.org/en-US/firefox/themes\n"
"https://addons.mozilla.org/en-US/firefox/addons/buttons.js?b=ea33612-5654d042")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")