const regex = /\bfrom\b(?!\s*#)([^w]*(?:\bw(?!here\b)[^w]*)*)\bwhere\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfrom\\b(?!\\s*#)([^w]*(?:\\bw(?!here\\b)[^w]*)*)\\bwhere\\b', 'g')
const str = `select ... from course c
where id = (select ... from student where ...)
select ... from #bar
where id = (select ... from student where ...)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}