$re = '/^- [^:]*: \K(.|\n)*?(?=^-|$)/m';
$str = '- item one: Amet Elit
- Title: One sentence with
a line break!
- Desc: Hello and thank you for your hell!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);