$re = '/^(\b\w+\b)[\w\W]+\1/m';
$str = 'ghbdtn kjfgkfjg fdkjsdlaj
kdfsjdlkjf kdjfkld ghbdtn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);