#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<errorMessage>([^<>]+)</errorMessage>"
Local $sString = " <?xml version="1.0" endcoding=UTF-8"?>" & @CRLF & _
" <n0:szemelyKutyaFuleResponsexmlns:prx="urn:sap.comproxy:SWP:/1SAI/TREASE1243804269AE457508F4:753" mmlns:n0="http://csajgeneratorws.tny.interfesz.kok.lo/">" & @CRLF & _
" <return>" & @CRLF & _
" <tanzakciosAzonosito>46981682-4637-49d2-bd4d-dcfff543742ed</tanzakciosAzonosito>" & @CRLF & _
" <erdmeny>HIBAS</eredmeny>" & @CRLF & _
" <errorCode>TSH08</errorCode>" & @CRLF & _
" <errorMessage>Azonosítószám már hozzá lett rendelve üzleti partnerhez</errorMessage>" & @CRLF & _
" </return>" & @CRLF & _
" </n0:szemelyKutyaFuleResponse>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")