$re = '/^(?:100(?:\.0{1,2})?|[1-9]\d?(?:\.\d{1,2})?|0\.(?!0+$)\d{1,2})$/m';
$str = '0
0.00
0.77
99.99
100
100.00
101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);