$re = '/(?<!=)=(?!=)/';
$str = 'if(y == 5 || x = 1) {
Do something ...
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);