const regex = /\/\*meta[^\*\/]*\*\/(?:\/\*meta[^\*\/]*\*\/)*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*meta[^\\*\\\/]*\\*\\\/(?:\\\/\\*meta[^\\*\\\/]*\\*\\\/)*', 'g')
const str = `/*meta asjgasl;kdjgask */
ghjkhjkghjk/* */
/*meta asjgasgask */
gjkghj
/*meta asjgasgask */
/*meta asjgasgask */`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}