import re
regex = re.compile(r"<img.*?src\s*=\s*(\"|')(?P<source>.*?)\1.*?>")
test_str = "<img src=\"/images/stories/News/NEWS_11_01_13_2.jpg\" alt=\"NEWS 11_01_13_2\" width=\"100\" height=\"67\" style=\"margin: 0px; padding: 0px; float: none; border: none;\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")