$re = '/<xsl:value-of\s+select="(\w+)"\s*\/>/';
$str = '<?xml version="1.0"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:template match="/Document">
<html>
<head>
</head>
<body>
<table>
<tr>
<td width="75"></td>
<td>
<table width="660" border="0">
<tr>
<td colspan="2" style=\'font-size:12.0pt;font-family:"Arial";text-align:left\'>
<xsl:value-of select="txtAdditionalInfo"/>
<br /><br />
<br />
</td>
</tr>
<tr>
<td align="left" height="32" valign="bottom">
</td>
<td align="left" height="32" valign="bottom" style=\'font-size:12.0pt;font-family:"Arial";text-align:left\'>
<xsl:value-of select="txtFormattedDate"/>
</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);