re = /^(?:(http|ftp|https|www):\/\/)?([\w+?\.\w+])+([a-zA-Z0-9\~\!\@\#\$\%\^\&\*\(\)_\-\=\+\\\/\?\.\:\;\'\,]*)?$/m
str = 'https://google.com
https://www.google.com
google.com
www.google.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end