const regex = /(?<NUMBER1>(?<=\D))(?<NUMBER2>(?=\d))|(?<NUMBER3>(?<=\d))(?<NUMBER4>(?=\D))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<NUMBER1>(?<=\\D))(?<NUMBER2>(?=\\d))|(?<NUMBER3>(?<=\\d))(?<NUMBER4>(?=\\D))', 'gs')
const str = `Test_01.tiff
Test_02.tiff
Test_03.tiff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}