const regex = /{{.*?}}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{.*?}}', '')
const str = `<p class=MsoNormal>{{input_box:greeting}},`;
const subst = `Hello There`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);