# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^NoticeText:(?:(?!\nNoticeText:)[\s\S])*\n\s+Text\s*\[str\]\s*=\s*"([^"]*)"(?:(?!\nNoticeText:)[\s\S])*/$1/gmix;t' <<< "NoticeText:
NoticeType [str] = USER_TYPING_ON
Text [str] = \"user is typing\"
EventInfo:
PartyId [int] = 2
EventType [str] = MESSAGE
UserNickname [str] = \"Michael\"
EventId [int] = 4
Text [str] = \"Hey, how are you?\"
MsgCheck [str] = NONE
TimeOffset [int] = 23
UserType [str] = AGENT
NoticeText:
NoticeType [str] = USER_TYPING_ON
EventInfo:
PartyId [int] = 1
EventType [str] = MESSAGE
UserNickname [str] = \"Bob Smith\"
EventId [int] = 6
Text [str] = \"I'm good, how are you?\"
MsgCheck [str] = NONE
TimeOffset [int] = 28
UserType [str] = CLIENT
MessageType [str] = \"text\""