re = /(?![0-9-+*\/()x]|abs|pow|ln|pi|e|a?(?:sin|cos|tan)h?)\b[a-zA-Z]+\b/
str = 'WIDTH+LENGTH*abs(2)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end