$re = '/(?:Blocked on|Parked on|Waiting on):[^@]*@(0x[0-9A-F]*) Owned by:[^<](0x[0-9]*|.*)[>]*/m';
$str = '3XMTHREADBLOCK Blocked on: java/util/Collections$SynchronizedMap@0x000000000B0D9A20 Owned by: "WebContainer : 10" (J9VMThread:0x00000000846F4900, java/lang/Thread:0x000000000B2E0A80)
3XMTHREADBLOCK Parked on: java/util/concurrent/locks/AbstractQueuedSynchronizer$ConditionObject@0x000000000296F1E8 Owned by: <unknown>This should not be captured in second group. Only <unknown> should be part of 2nd group
3XMTHREADBLOCK Waiting on: java/util/TaskQueue@0x0000000030A0C590 Owned by: <unowned>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);