re = /(?<!\\)\\(?!\\)/m
str = '\\This string\\\\ \\contains some\\ backslashes\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end