re = /\{\{\w+\}\}(*SKIP)(*FAIL)|(\w+)/m
str = 'some
thing
work {{word}}
work red tex
add
red'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end