$re = '/ (?!-)|(?=-)/m';
$str = '19 20 22 -1 -3-4-10 -7 2 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);