$re = '/(?<=[<>=])(?=\d)/';
$str = '>=1_2_3
<2_3_2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);