import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\u0020\\u0009\\u000A\\u000C\\u000D]*([^,\\u0020\\u0009\\u000A\\u000C\\u000D][^\\u0020\\u0009\\u000A\\u000C\\u000D]*[^,\\u0020\\u0009\\u000A\\u000C\\u000D]?)(?:(?:[\\u0020\\u0009\\u000A\\u000C\\u000D]+(\\d+w))|(?:[\\u0020\\u0009\\u000A\\u000C\\u000D]+(\\d+(?:\\.\\d+)?(?:[eE][+-]?\\d+)?x)))?[\\u0020\\u0009\\u000A\\u000C\\u000D]*";
final String string = "medium.jpg 1000w, large.jpg 2000w";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}